db2 9.7安装在centos7.6上报错发生了较小的错误:SA MP故障?

cat /tmp/db2_install.log.32480

操作系统信息:Linux 3.10.0-123.el7.x86_64.#1 SMP Mon Jun 30 12:09:22 UTC 2014 x86_64 
警告: 尚未指定通知 SMTP 服务器。在指定通知 SMTP
服务器之后才能将通知发送给联系人列表中的联系人。有关
更多信息,请参阅 DB2 管理文档。

                                        
要安装的产品:                      DB2 企业服务器版 
                                        
先前安装的组件:                
所选组件:                         
    基本客户机支持                  
    Java 支持                            
    SQL 过程                             
    基本服务器支持                  
    IBM Java? 软件开发包(SDK)     
    连接支持                           
    通信支持 - TCP/IP                
    复制工具                           
    控制中心                           
    DB2 数据源支持                    
    DB2 LDAP 支持                        
    “DB2 实例安装”向导           
    Spatial Extender 客户机             
    基本应用程序开发工具         
    DB2 更新服务                       
    第一步                              
    样本数据库源                     
    DB2 文本搜索                       
    Informix 数据源支持               
                                        
语言:                               
                                        
目标目录:                            /opt/ibm/db2/V9.7
                                        
需要的空间:                         1095 MB
安装 SA MP:                            否 
                                        
                                        

TSAMP_VERSION=3.1.0.1
 DBI1130E  由于未满足系统先决条件,因此未能安装或更新 IBM Tivoli 
      System Automation for Multiplatforms(SA MP)基本组件。请参阅日志
      文件 /tmp/prereqSAM.log.33658 以了解详细信息。

说明: 

安装或更新 SA MP 基本组件时需要满足一些系统先决条件。但这些先决条件未得
到满足。

提及的日志文件提供了未得到满足的先决条件的详细信息。

有关 SA MP 基本组件系统先决条件的更多信息,请参阅《安装和配置指南》,网
址为:http://publib.boulder.ibm.com/tividd/td/
IBMTivoliSystemAutomationforMultiplatforms2.2.html。

不能安装或更新 SA MP 基本组件。

用户响应: 

请修改系统以满足先决条件,并使用 installSAM 实用程序来手动安装 SA MP 基
本组件。

TSAMP_VERSION=3.1.0.1
 DBI1130E  由于未满足系统先决条件,因此未能安装或更新 IBM Tivoli 
      System Automation for Multiplatforms(SA MP)基本组件。请参阅日志
      文件 /tmp/prereqSAM.log.69511 以了解详细信息。

说明: 

安装或更新 SA MP 基本组件时需要满足一些系统先决条件。但这些先决条件未得
到满足。

提及的日志文件提供了未得到满足的先决条件的详细信息。

有关 SA MP 基本组件系统先决条件的更多信息,请参阅《安装和配置指南》,网
址为:http://publib.boulder.ibm.com/tividd/td/
IBMTivoliSystemAutomationforMultiplatforms2.2.html。

单独安装SA MP报错:
prereqSAM: 错误:以下分发不受支持@
prereqSAM: 错误:ITSAMP 安装的必备软件检查失败@ Linux i386x 
CentOS Linux release 7.6.1810 (Core) 
prereqSAM: 返回了极其严重的错误代码@ 23
prereqSAM: 无法执行必备软件检查?
prereqSAM: 有关详细信息,请参阅日志文件中的“错误:”条目@ /tmp/installSAM.2.lo

2回答

冯岩冯岩  数据库管理员 , 银行
KiKibj泊涯zhuhaiqiang赞同了此回答
您的 TSA 版本是 v3.1( TSAMP_VERSION=3.1.0.1 ),您的操作系统  Centos7.6 对应的 Redhat 7系列,是不支持安装 TSA v3.1 的 tsamp 3.1支持的操作系统如下: 使用安装包解压目录中的  prereqSAM 命令生成预备条件检查日志,看看日志更详细的信息。 当然,你可以通过修...显示全部

您的 TSA 版本是 v3.1( TSAMP_VERSION=3.1.0.1 ),您的操作系统  Centos7.6 对应的 Redhat 7系列,是不支持安装 TSA v3.1 的

tsamp 3.1支持的操作系统如下:

使用安装包解压目录中的  prereqSAM 命令生成预备条件检查日志,看看日志更详细的信息。

当然,你可以通过修改  /etc/redhat-release文件内容为 redhat 5 的相关内容骗过版本验证,
或者通过下面的命令跳过安装时的验证过程:
./installSAM --noprereqcheck

当然,安装过程估计还会报许多依赖包缺失的错误,到时候根据日志再安装一下相关的包,但是,由于您使用的版本和 TSA 3.1支持的版本差的太多,直觉上成功安装的几率不高。

收起
 2019-12-06
浏览996
aixchina 邀答
icycastleicycastle  数据库管理员 , 某证券公司
TSAMP可能会和其他HA软件冲突,如果确认不适用TSAMP,可以不安装。 ./db2_install -b $DB2DIR -l /tmp/db2install.log -f NOTSAMP显示全部

TSAMP可能会和其他HA软件冲突,如果确认不适用TSAMP,可以不安装。

./db2_install -b $DB2DIR -l /tmp/db2install.log -f NOTSAMP

收起
 2019-12-20
浏览914
aixchina 邀答

提问者

hufeng719系统工程师, 某钢铁企业

问题状态

  • 发布时间:2019-12-05
  • 关注会员:3 人
  • 问题浏览:2199
  • 最近回答:2019-12-20