WAS与elasticsearch结合的问题?

我公司使用的WAS的版本为8.5,jdk为1.6,安装es的jdk为1.8,应用程序部署在WAS上面,想问一下,由于两边jdk版本不一致,es安装版本是不是有要求,只能安装最低版本啊。有什么办法可以解决这种问题吗?...显示全部

我公司使用的WAS的版本为8.5,jdk为1.6,安装es的jdk为1.8,应用程序部署在WAS上面,想问一下,由于两边jdk版本不一致,es安装版本是不是有要求,只能安装最低版本啊。有什么办法可以解决这种问题吗?

收起

查看其它 2 个回答niesin的回答

niesinniesin  系统工程师 , IBM

WAS的JDK是WAS安装时自带的,默认安装在<WAS home>/java下,WAS 8.5默认安装JDK 1.6,也可以选择安装 1.7和1.8.
ES可以使用操作系统的JDK,两者互相独立。

 2019-09-01
浏览700

回答者

niesin系统工程师, IBM

分布式关系型数据库选型优先顺序调查

发表您的选型观点,参与即得50金币。

回答状态

  • 发布时间:2019-09-01
  • 关注会员:4 人
  • 回答浏览:700