WAS与elasticsearch结合的问题?

我公司使用的WAS的版本为8.5,jdk为1.6,安装es的jdk为1.8,应用程序部署在WAS上面,想问一下,由于两边jdk版本不一致,es安装版本是不是有要求,只能安装最低版本啊。有什么办法可以解决这种问题吗?

3回答

hbhe0316hbhe0316  数据库管理员 , IBM
泊涯张颖颖niesin等赞同了此回答
Was是IBM自带的jdk,es可以用oracle的jdk,两者没有联系。显示全部

Was是IBM自带的jdk,es可以用oracle的jdk,两者没有联系。

收起
 2019-08-30
浏览359
aixchina 邀答
俞黎敏俞黎敏  软件开发工程师 , IBM广州
简单的办法就是给WAS 8.5安装上IBM JDK8,然后你的ElasticSearch也一起用IBM JDK 8,方便进行,不过两者是分开的,也无所谓。显示全部

简单的办法就是给WAS 8.5安装上IBM JDK8,然后你的ElasticSearch也一起用IBM JDK 8,方便进行,不过两者是分开的,也无所谓。

收起
 2019-11-28
浏览19
niesinniesin  系统工程师 , IBM
WAS的JDK是WAS安装时自带的,默认安装在<WAS home>/java下,WAS 8.5默认安装JDK 1.6,也可以选择安装 1.7和1.8.ES可以使用操作系统的JDK,两者互相独立。显示全部

WAS的JDK是WAS安装时自带的,默认安装在<WAS home>/java下,WAS 8.5默认安装JDK 1.6,也可以选择安装 1.7和1.8.
ES可以使用操作系统的JDK,两者互相独立。

收起
 2019-09-01
浏览311

提问者

fantl软件开发工程师, 北京国电南自亿通科技有限公司

问题状态

  • 发布时间:2019-08-30
  • 关注会员:4 人
  • 问题浏览:1330
  • 最近回答:2019-11-28
  • 关于TWT  使用指南  社区专家合作  厂商入驻社区  企业招聘  投诉建议  版权与免责声明  联系我们
    © 2019  talkwithtrend — talk with trend,talk with technologist 京ICP备09031017号-30