aix 7.1.4安装gcc, 总是提示缺少依赖库,请问这是什么原因导致的?

aix 7.1.4 安装gcc, 总是提示缺少依赖库,哪位大哥帮帮忙啊,不知道是GCC版本问题,还是缺少必要组件
    libgcc-4.9.3-1.aix6.1.ppc.rpm
    libstdc++-4.9.3-1.aix6.1.ppc.rpm
    libstdc++-devel-4.9.3-1.aix6.1.ppc .rpm 
    gcc-4.9.3-1.aix6.1.ppc.rpm
    gcc-c++-4.9.3-1.aix6.1.ppc.rpm
再安装gcc-4.9.3-1.aix6.1.ppc.rpm的时候 

rpm -ivh gcc-4.9.3-1.aix6.1.ppc.rpm 

error: failed dependencies:
        info is needed by gcc-4.9.3-1
        gcc-cpp = 4.9.3-1 is needed by gcc-4.9.3-1
        libiconv >= 1.14-3 is needed by gcc-4.9.3-1
        libiconv.a(libiconv.so.2) is needed by gcc-4.9.3-1
怎么解决啊

5回答

a520520168a520520168  系统工程师 , 索菲亚
zhuhaiqiang郑远金挚爱咖啡等赞同了此回答
先解决依赖包的问题啊,或者一并安装试试显示全部

先解决依赖包的问题啊,或者一并安装试试

收起
 2019-08-05
浏览690
我是限量版我是限量版  软件开发工程师 , NXY
郑远金赞同了此回答
我也想问一下,怎么解决这个问题,我安装上了gcc,但是执行一直报错显示全部

我也想问一下,怎么解决这个问题,我安装上了gcc,但是执行一直报错

收起
 2019-08-06
浏览632
yjcx640yjcx640  测试工程师 , 北京通州电子世界
郑远金赞同了此回答
请问需要哪个依赖包啊,看不明白,也下载不到啊显示全部

请问需要哪个依赖包啊,看不明白,也下载不到啊

收起
 2019-08-05
浏览656
邓毓邓毓  系统工程师 , 江西农信
拿AIX7.1版本的光盘或者镜像挂载,再去找GCC安装吧,你这安装的6.1的,会缺很多依赖包的。显示全部

拿AIX7.1版本的光盘或者镜像挂载,再去找GCC安装吧,你这安装的6.1的,会缺很多依赖包的。

收起
 2天前
浏览15
周文周文  系统运维工程师 , 网龙
你装的版本太低了吧,而且好像叫XLC还是什么的,不叫gcc吧,我前段时间从9升级到11还是12忘记了,好像没啥问题,编译出的程序也没啥问题。具体忘记包名叫啥了,但是肯定不是gcc。显示全部

你装的版本太低了吧,而且好像叫XLC还是什么的,不叫gcc吧,我前段时间从9升级到11还是12忘记了,好像没啥问题,编译出的程序也没啥问题。具体忘记包名叫啥了,但是肯定不是gcc。

收起
 2019-12-26
浏览305

提问者

yjcx640测试工程师, 北京通州电子世界

问题状态

  • 发布时间:2019-08-05
  • 关注会员:5 人
  • 问题浏览:1662
  • 最近回答:2天前