aix 5.3的服务器该淘汰了,如果要保持原有应用不变,请问有什么好的解决办法?

我们这里有2台p550 +aix5.3+oracle9i 组成的双机,随着时间的推移,这套生产系统也将走向末端。想继续使用aix 5.3+oracle9i,因为小机里有oracle 开发的程序,不想改变环境,否则太复杂。还有什么好办法搭建这样的环境?

11回答

张文正张文正  系统工程师 , dcits
z_zwz99999yinxinmichael1983等赞同了此回答
这样的情况下只能迁移到新的服务器上,目前p7的是支持5.3的 ,还有一种是采用wpar技术迁移到p8 上显示全部

这样的情况下只能迁移到新的服务器上,目前p7的是支持5.3的 ,还有一种是采用wpar技术迁移到p8 上

收起
 2019-08-27
浏览1428
aixchina 邀答
reniwxfreniwxf  系统运维工程师 , LYT
神次方赞同了此回答
我在2014年工作中接触过,环境和你的差不多,AIX5.3+ Oracle9i双机,一台p55a一台p52a组DG,当时性能已经很吃紧,经常耗尽需要重启,于是把主库升级成p730,忘了是什么原因没法直接跑原有环境,就在p730 AIX 7.1下面创建一个wpar aix5.3+oracle9i,把主库放在里面跑,p55a改成备库,p52a下架...显示全部

我在2014年工作中接触过,环境和你的差不多,AIX5.3+ Oracle9i双机,一台p55a一台p52a组DG,当时性能已经很吃紧,经常耗尽需要重启,于是把主库升级成p730,忘了是什么原因没法直接跑原有环境,就在p730 AIX 7.1下面创建一个wpar aix5.3+oracle9i,把主库放在里面跑,p55a改成备库,p52a下架,现在那个生产环境还在继续用也没出现过致命问题,性能也完全够用,但是这种WPAR的架构总感觉实属下策,如果业务能跟着升级最好一起升了直接跑物理机吧,以后还是得面临同样的问题。

收起
 2019-08-27
浏览1328
zihan524524zihan524524  其它 , 某银行
p8上用vios啊。再安装5312的aix客户端。显示全部

p8上用vios啊。再安装5312的aix客户端。

收起
 2019-11-09
浏览875
lonebird2008lonebird2008  项目经理 , 四川久远银海软件股份有限公司
升有环境,HAMCP做LVM镜像迁移显示全部

升有环境,HAMCP做LVM镜像迁移

收起
 2019-09-18
浏览1044
aixchina 邀答
caiwencaiwen  系统工程师 , 南京中铁信息工程有限公司
alt_disk_install到存储上,通过SAN BOOT克隆到新小机上。显示全部

alt_disk_install到存储上,通过SAN BOOT克隆到新小机上。

收起
 2019-09-02
浏览1159
王巧雷王巧雷  系统工程师 , sino-bridge
1. 应用和os升级,使用p8或者p9   这个最好了 2. 如果条件不允许升级,买个二手的p7还可以用,找第三方维保 3. 如果一定用最新硬件,用versioned wpar  把aix5.3备份成mksysb,恢复到aix7.1的wpar里。和VMware workstation类似。也对版本有限制,印象是5310以后的...显示全部

1. 应用和os升级,使用p8或者p9   这个最好了

2. 如果条件不允许升级,买个二手的p7还可以用,找第三方维保

3. 如果一定用最新硬件,用versioned wpar  把aix5.3备份成mksysb,恢复到aix7.1的wpar里。和VMware workstation类似。也对版本有限制,印象是5310以后的

收起
 2019-09-02
浏览1180
aixchina 邀答
asdf-asdfasdf-asdf  研究学者 , cloudstone
升级操作系统  部署到新power上,  oracle9i  应该还支持aix6的显示全部

升级操作系统  部署到新power上,  oracle9i  应该还支持aix6的

收起
 2019-08-29
浏览1268
aixchina 邀答
kakakaiikakakaii  项目经理 , 某国企集成商
如果只是数据库,和操作系统和数据库版本有啥关大关系能。我觉得应用架构才是你考虑是否动系统架构的关键。显示全部

如果只是数据库,和操作系统和数据库版本有啥关大关系能。我觉得应用架构才是你考虑是否动系统架构的关键。

收起
 2019-08-29
浏览1272
zcomezcome  系统工程师 , zzz
如果你的版本是最新的5300-12-09,应该还能在power8上使用,但是需要一个power8的兼容补丁,而且有挺多限制。。。The PTF enables 5.3 TL12 support with the following limitations: · The LPAR must be at AIX 5.3 TL12 SP9 (latest 5.3 release). · The Power8 LPAR wi...显示全部

如果你的版本是最新的5300-12-09,应该还能在power8上使用,但是需要一个power8的兼容补丁,而且有挺多限制。。。
The PTF enables 5.3 TL12 support with the following limitations:

· The LPAR must be at AIX 5.3 TL12 SP9 (latest 5.3 release).

· The Power8 LPAR will run in Power6 compatibility mode and is limited to SMT2 mode, which is the natural operating mode for AIX 5.3. Power8 servers can support SMT4 and SMT8 modes as well that are available to more current AIX releases. IBM publishes SMT2 rPerf values that can be used to quantify Power8 SMT2 capacity

· 5.3 Power8 LPARs only support Virtual I/O configurations: vSCSI , NPIV, VLAN. AIX 5.3 does not support 4K sector size storage. Any storage virtualized to 5.3 LPARs must use 512 byte sectors.

· Power8 systems support a minimum entitlement of 0.05 physical processor units per VCPU (virtual processor). AIX 5.3 requires 0.1 physical processor units per virtual processor. If a 5.3 Power8 LPAR does not have sufficient entitlement, it will fail to start.

· 5.3 LPARs support a 64 VCPU maximum. Power8 systems allow LPARs with larger VCPU configurations. If more than 64 VCPUs are assigned to a 5.3 LPAR, it will fail to start.

Only 5.3 Power8 installation methods are supported:

· mksysb – First perform an in place update to a supported (P5/P6/P7) 5.3 TL12 SP9 LPAR with PTF U866665. Standard mksysb command can then be used to capture a P8-capable mksysb image. The mksysb image can then be used to install Power8 LPARs.

· NIM – A 5.3 TL12 SP9 NIM environment must be updated to support Power8. A 5.3 TL12 SP9 NIM lpp_source must be updated to include PTF U866665. A NIM SPOT must then be created or updated to utilize the updated lpp_source .

· LPM – First perform an in place update to a supported (P6/P7 ) 5.3 TL12 SP9 LPAR with PTF U866665. The update is not concurrent so an LPAR restart is required. Once the LPAR has been restarted, LPM can be used to migrate to a Power8 system. The P6/P7 LPM source must use VIOS 2.2.2.70/2.2.3.50/2.2.4.10 (or later) and any supported firmware level.

All Power8 systems are supported with the following restrictions:

· Power8 system must be at 840 firmware level

· Power8 LPAR must be served by a 2.2.4.10 or 2.2.3.60 VIOS

Other restrictions:

· Remote restart is not supported with Power8 5.3 LPARs

· Power8 5.3 LPARs are not supported with a VIOS using Shared Storage Pools.

收起
 2019-08-27
浏览1385
匿名用户匿名用户
[此回答已删除]
浏览1274

提问者

liyong8163网站开发工程师, 内蒙古新联

核心数据库服务器选型优先顺序调查

发表您的选型观点,参与即得50金币。

问题状态

  • 发布时间:2019-08-27
  • 关注会员:12 人
  • 问题浏览:5021
  • 最近回答:2019-11-09