AIX中编译软件的问题

各位大侠,请教个问题,一直没弄明白,AIX中如何知道要安装的软件是哪个包?比如装GCC、C++编译器,不知道到官网找哪个包?
OS VERSION:AIX 5.3.0.0
GCC VERSION:4.3.2
还有,今天下载了一个GCC的包,自己编译的时候第一步就遇到问题了,步骤如下:
# cd gcc-4.3.2
# ls -l configure
-rwxrwxr-x   1 1003     1003         402373 Feb 02 2008  configure
# ./configure --prefix=/usr/gcc4
configure: error: cannot run /bin/sh ./config.sub
#

6回答

szhangkangszhangkang  项目经理 , 神州数码
把你编译的详细过程列出来。系统版本,gcc版本。显示全部
把你编译的详细过程列出来。系统版本,gcc版本。收起
 2012-10-09
浏览13
dba_xyxdba_xyx  数据库管理员 , asia
回复 2# szhangkang     大致操作步骤就是这样,版本也贴出来了,版主还需要提供啥信息?显示全部
回复 2# szhangkang


    大致操作步骤就是这样,版本也贴出来了,版主还需要提供啥信息?收起
 2012-10-09
浏览15
bjibm1188bjibm1188  系统工程师 , DCITS
现在系统中都没有编译器,你用编译方式安装能装上吗?直接到IBM官网下载bff或rpm包安装gcc or c++。显示全部
现在系统中都没有编译器,你用编译方式安装能装上吗?直接到IBM官网下载bff或rpm包安装gcc or c++。收起
 2012-10-10
浏览18
quiowquiow  系统运维工程师 , 中国工商银行软件开发中心
Version 4.3.6AIX5L v5.3: gcc-4.3.6-2.aix5.3.ppc.rpmgcc-c++-4.3.6-2.aix5.3.ppc.rpmgcc-cpp-4.3.6-2.aix5.3.ppc.rpmgcc-gfortran-4.3.6-2.aix5.3.ppc.rpmlibgcc-4.3.6-2.aix5.3.ppc.rpmlibgomp-4.3.6-2.aix5.3.ppc.rpmlibstdc++-4.3.6-2.aix5.3.ppc.rpmlibstdc++-dev...显示全部
 2012-10-10
浏览26
dba_xyxdba_xyx  数据库管理员 , asia
好的,非常感谢显示全部
好的,非常感谢收起
 2012-10-10
浏览14
dba_xyxdba_xyx  数据库管理员 , asia
回复 5# quiow    不行,很多缺少依赖关系的包,还是到官网找bff吧显示全部
回复 5# quiow


   不行,很多缺少依赖关系的包,还是到官网找bff吧收起
 2012-10-10
浏览13

提问者

dba_xyx数据库管理员, asia

问题状态

  • 发布时间:2012-10-09
  • 关注会员:1 人
  • 问题浏览:1977
  • 最近回答:2012-10-10
  • 关于TWT  使用指南  社区专家合作  厂商入驻社区  企业招聘  投诉建议  版权与免责声明  联系我们
    © 2017 talkwithtrend — talk with trend,talk with technologist 京ICP备09031017号-30